Nextcloud on CasaOS: "dependency failed to start: container db-nextcloud is unhealthy"

Could you try in big-bear-casaos the Nextcloud LS?

Hello. I’m sorry for the late reply. I tried the script with big-bear-nextcloud. When i opened it with nano, it said at the bottom “[ Error reading /var/lib/casaos/apps/big-bear-nextcloud/docker-compose.yml: Permission denied ]” and the file was empty. This is the output of the script after i ran it.

utilizator@raspberrypi:~ $ bash -c "$(wget -qLO -"
Welcome to the CasaOS App Editor.
Available apps:
big-bear-dozzle  big-bear-nextcloud  calibre-web  jellyfin  lidarr  nextcloud  radarr  sonarr  uplifting_rik
Enter the name of the app you want to edit: big-bear-nextcloud
Please select an editor:
1. nano
2. vim
Enter your choice (1 or 2): 1
environment: line 13: 471847 Segmentation fault      casaos-cli app-management apply "$service_name" --file="$docker_compose_path"
Editing complete.

I also tried to manually create the folders and reinstalling big-bear-nextcloud.

PS: What do you mean by Nextcloud LS?

There is an app in BigBearCasaOS that I added so maybe I can figure out if it will work with your PI 5. It’s hard to reproduce this issue when I don’t have a Pi 5.

I’m sorry but in my CasaOS App Store there is no Nextcloud LS in my BigBearCasaOS source. I have added LinuxServer as a source and their nextcloud shows up. Here is a screenshot:

Can you try to remove the BigBearCasaOS store and re-add it?

With so many glitches happening with your system, you might think about reinstalling CasaOS, which sometimes fixes a lot of issues for people.

I tried to re-add BigBearCasaOS and it still doesn’t show up. Maybe it’s because i have LinuxServer already set as a source? Anyway, will reinstalling CasaOS remove my data?

You will need to watch the prompts and don’t delete the AppData. I would recommend a backup before running the reinstall.

You docker compose is at:


AppData is at: