Added Pihole to BigBearCasaOS


Pi-hole is a Linux network-level advertisement and Internet tracker blocking application which acts as a DNS sinkhole and optionally a DHCP server, intended for use on a private network.

Install the App Store



I would change the WEBPASSWORD environment variable.

You can check if port 53 is clear with running:

bash -c "$(wget -qLO -"

Docker Image

Hi, I’m trying to set up pihole on a Rpi 4 8GB.
When I run the Bash script you provided (many thanks!) I get this message:

This will display processes using port 53 and then disable systemd-resolved. Continue? (y/n): y
Disabling and stopping systemd-resolved...
Failed to disable unit: Unit file systemd-resolved.service does not exist.
Failed to stop systemd-resolved.service: Unit systemd-resolved.service not loaded.
Checking if port 53 is clear...
Port 53 is still in use.

I run CasaOS in a Rpi 4 8GB.
I’ve installed CasaOS using the Bash on their website.

Any idea how to resolve?

I would als like to thank you for the great resource you’re building for a noob like me.

Check and see if port 53 is taken by another process:

lsof -i :53


netstat -tulpn | grep ":53 "

I get no result from

lsof -i :53

the other command gives

~ $ netstat -tulpn | grep ":53 "
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp        0      0    *               LISTEN      -                   
tcp6       0      0 :::53                   :::*                    LISTEN      -                   
udp        0      0    *                           -                   
udp6       0      0 :::53                   :::*                                -                   

When in root I get this

/# netstat -tulpn | grep ":53 "
tcp        0      0    *               LISTEN      19453/docker-proxy  
tcp6       0      0 :::53                   :::*                    LISTEN      19459/docker-proxy  
udp        0      0    *                           19474/docker-proxy  
udp6       0      0 :::53                   :::*                                19481/docker-proxy 

A Docker container is using port 53; that’s why it says docker-proxy You would need to find out which Docker container is using the port. You can do that by going into the settings for each Docker container in the CasaOS UI.

I have portainer running. This is what it shows me.

So it’s pihole that is using port 53.

Yes, it looks like it’s setup correctly on that stand point.

Could be that it all is set up as should be and I’m just making things complicated?

My further setup is as followed:

  • My Rpi has a fixed ip that I gave through my router
  • The pihole’s web UI is set at
  • My router uses as primary DNS
  • I’ve set the upstream DNS at in my pihole

Are these settings correct?

It looks good to me You can test it by running


So, I’ve let it rest for a while because I was getting frustraded.
Today I’ve uninstalled pihole and reinstalled it. Started with a fresh config on my router and it just works…

I have no idea what went wrong with the former install but hey, it’s working now.

I would like to thank you once more for the awsome resource you are building here.

That’s awesome; it’s working. Sometimes you just need to take a break. That’s what I do sometimes when I can’t figure something out. You’re welcome!