Adding entry A in DNS

After adding an entry in the Local DNS Records [A/AAAA] menu, the name is not resolved.

I have correctly assigned a dns server (pihole) to the client from which I connect. Pinging the address is correct, on the firewall I also have no blocking rules for the address and

Nslookup does not resolve the name. I did not restart the pi hole after adding the name in the A record - but it should not be necessary.

How to make a client hooked up to dns read entries added manually. I got the Pi-Hole and configuration from your repository:

DNS Cache: The local DNS cache on the client or within Pi-hole itself might not have updated yet to reflect the new A record. Although restarting Pi-hole isn’t generally necessary for changes to take effect, it can help ensure that all services reload their configuration and clear their cache.

Flush DNS Cache: On the client machine, flush the DNS cache to ensure that old DNS resolutions are not being used. On Windows, this can be done by running:

ipconfig /flushdns

Local DNS Resolution: Verify that the client is indeed using Pi-hole as its DNS resolver. You can do this by running nslookup and specifying the Pi-hole server explicitly. For example:


This will force nslookup to query your Pi-hole directly. If this resolves correctly, it confirms that the issue might be with the DNS settings on the client rather than Pi-hole itself.

Test with Different Device: Try resolving srv-sstudio from a different device that uses Pi-hole as its DNS server to see if the issue is isolated to a single client or is global across all devices.