AdGuard Home does not run properly via CasaOS

Hi everyone!

I have issues with AdGuard Home via CasaOS. Where the problem lies or what exactly is not working is unfortunately beyond my knowledge.
I have followed all the steps shown in BigBearTech’s YouTube video accurately. However, AdGuard does not seem to work properly. The dashboard stays conspicuously inconspicuous. I assume that no queries via my home network are being filtered by AdGuard.
In addition, I have set the DHCP server in my router to the IP of CasaOS. That should be correct, right? Because AdGuard basically runs via CasaOS.

I have checked the possible source of the issue caused by the occupied port 53 and this should not be the case. My AdGuard dashboard can be found in the attachment.

I sincerely hope for a solution and would be grateful for any help.

P.S. Maybe it’s not that important, but I use the latest Firefox as my browser and macOS as my operating system. Previously I had AdGuard running on my Pi4 without any problems. However, it seems to work differently via casaOS.

Hello again!

AdGuard Home is still not working. Just don’t understand what the problem is. Does anyone have any ideas? I am totally desperate.

I wanted to replace the Raspberry Pi 4 with the Zimablade and finally combine a NAS with the AdBlocker in one system.

Can you try to run:

nslookup replace_with_your_casaos_lan_ip

I have tried it once without and once with sudo, but without success. Here is the result:

Can you try it from your computer, not on the CasaOS server?

Sure, here you go:

On the CasaOS server, what do you get when running:

lsof -i :53



Am I doing something wrong or why is AdGuard not working?
Could the problem be port 80? I really want to understand why it’s not working or what the problem is.

Since it doesn’t seem to work for whatever reason and I can’t get any further with AdGuard via CasaOS, I’m considering installing either TrueNAS, OpenMediaVault or Unraid. Even though I really like the look of CasaOS. Would you still advise me to make the switch?

What’s the result of:

docker ps -a

That’s what I’m trying to figure out.

In the CasaOS App settings change Host Port 531 to 53.

Which one do you mean? TCP or UDP or both?

Change Host Port 531 to 53.

1 Like

I did it for both, but no changes on the AdGuard Home dashboard.

Edit: My fault. I was to impatient. It finally works now. Thank you so much!!!

1 Like

You’re welcome! Glad it’s working for you now!