App may not be available error on Immich

finding issues settong up immich on bb casaos. After the installation, i tried launching and it gave me this error.

Can you check the logs and see which container didn’t start?

These are the logs for immich-typesense

nom@nom:~ $ sudo bash -c "$(wget -qLO -"
Select a container to fetch logs:
1) immich-microservices     3) immich-machine-learning  5) immich-redis             7) jellyfin
2) immich-server            4) immich-postgres          6) immich-typesense         8) cloudflared
#? 6
<jemalloc>: Unsupported system page size
<jemalloc>: Unsupported system page size
terminate called without an active exception
<jemalloc>: Unsupported system page size

When you run docker ps -a which containers are not running? I would need more information.

Thanks for your response, I got this after i ran docker ps -a

nom@nom:~ $ sudo docker ps -a
CONTAINER ID   IMAGE                                                COMMAND                  CREATED       STATUS                            PORTS
f3036504d63e             "tini -- /bin/sh sta…"   8 hours ago   Up 23 seconds                     3001/tcp
de8c4371eaca             "tini -- /bin/sh sta…"   8 hours ago   Up 23 seconds           >3001/tcp, :::2283->3001/tcp
df6783821b76   "tini -- ./"     8 hours ago   Up 3 minutes 
8cc9a25b85a8   postgres:14-alpine                                   "docker-entrypoint.s…"   8 hours ago   Up 3 minutes                      5432/tcp
d022b2d4f5d0   redis:6.2-alpine                                     "docker-entrypoint.s…"   8 hours ago   Up 3 minutes                      6379/tcp
48b39c7e71ed   typesense/typesense:0.24.1                           "/opt/typesense-serv…"   8 hours ago   Restarting (133) 56 seconds ago
8ac2a81581e5   linuxserver/jellyfin:10.8.12                         "/init"                  4 days ago    Up 3 minutes            >7359/tcp, :::7359->7359/tcp,>1900/tcp, :::1901->1900/tcp,>8096/tcp, :::8097->8096/tcp,>8920/tcp, :::8921->8920/tcp   jellyfin
d90de2978a46   wisdomsky/cloudflared-web:2023.10.0                  "/bin/sh -c 'node /v…"   4 days ago    Up 3 minutes 

What’s your CPU Arch? ARM?

Can you run:

getconf PAGE_SIZE

and post your page size.

I have been running this on a Raspberry Pi 5. AArch 64 OS architecture, ARM cortext-A76 processor. 64 bit PI OS lite.

getconf PAGE_SIZE

Typesense is using Jemalloc, which only works with 4096 pages.

In the latest Immich, it looks like they removed typesense.

It’s been the holidays, and I haven’t had a chance to update Immich yet.

I updated Immich:


Oh I see, will wait for the next update. Anyways thanks for helping me figuring out the issue.

The update is out in the BigBearCasaOS. You can try it and see if it fixes your issue. It more than likely will, since they don’t depend on Typesense anymore.

The App Store in CasaOS updates, but you can force it by removing BigBearCasaOS and then re-adding the App Store again.

Thanks again, checking it out now

It works!! Thanks a lot for taking out your time during holidays. Appreciate it