CasaOs/Immich - i cant add my external drive on IMMICH

Hello
I need some help

I’ve installed immich but i cant add my mounted drive into it ( which is working fine on jellyfin)

maybe is something i’m doing it wrong.

Thanks

Hi @FurtzBR,

in the last screenshot (Add Import Path) the path should not be /CasaOS/PHOTOS as you used in the container configuration?

basically is the same from first printscreen, casaos config
which is the path from external drive mounted, maybe this is the setup i did it wrong, i dont know.

@FurtzBR once you are inside the container you have to use the mapped path.
Try to change to /CasaOS/PHOTOS on Add Import Path screen.

same error

add path: /CasaOS/PHOTOS

in casaos are only set in microservices and sever, following this print

I think that is enough.
Use this command in terminal,
docker exec -it immich-server /bin/bash

try to navigate to the folder that you want and create a file there, check if you able to create.
cd /CasaOS/PHOTOS
touch test.txt

now check if the file exist in Files App from CasaOS

this worked at least

what is should do now?

casaos1

can you provide the screenshots of the screen “Add Import Path” in Immich with the path “/CasaOS/PHOTOS” showing that it is not working?

Ok

what i did

  1. Create External Library
  2. Add path, paste: /CasaOS/PHOTOS
  3. Add button
  4. error pops-up

1 Like

Hm I see.

My config is different of your, I have been using an external drive(samba share), and I mapped the entire app to be inside this drive.

Bro, I added you on discord, can you check there if you receive a new friend invitation.
If we solved it there we can post the solution here.

Also I found out this instruction:

  1. Update Container Paths:
  • Locate the configuration sections for immich-server: and immich-microservices: in your CasaOS UI.
  • In both sections, change the container path to /usr/src/app/external. Ensure this line is added identically in both sections to maintain consistency.
  1. Set an Environment Variable:
  • Add the following environment variable to both the immich-server and immich-microservices:
EXTERNAL_PATH=/mnt/pve/CasaOS/PHOTOS
  1. Integrate External Library:
  • Now, add the external library by specifying its path. Use the path /usr/src/app/external for this purpose.
  1. Include Import Path:
  1. Scan New Library Files:
  • Finally, initiate a process.

Remember that containers can’t see host paths, only container paths.

Detailed step-by-step instructions are here as well. External Library | Immich

2 Likes

This community does have a real-time chat as well :slight_smile: Also thanks for helping out!

1 Like

Hi @dragonfire1119, we only see your message now.

We have already made another strategy we changed that default folder /DATA to /mnt/pve/CasaOS/PHOTOS.

And now it’s working.

Thank you so much @Guilherme

and @dragonfire1119 for showing up as well with another way to solve it.

1 Like

You’re welcome. I’m glad it’s working!