Immich .env file location

I want to change my upload location, but I can’t find the.env file inside the docker folder. Am missing something? Do I need to install docker composer too?

Could you give me more information?

  • What platform are you using?
  • Did you follow a YouTube video on BigBearTechWorld?

a Dell optiplex USFF, running debian 12.1 x86_64 / amd64, followed this instructions: https://www.youtube.com/watch?v=ZIx2jDHYjjE&t=346s&ab_channel=BigBearTechWorld

current setup is uploading files directly to my internal drive 256 nvme, however I need to move everything to my share 2tb also internal SATA.

You can mount the 2tb to the

/DATA/AppData/big-bear-immich/upload

Instructions

  1. Temporarily Mount the 2TB Drive: First, if the 2TB drive is not already formatted and partitioned, you should do so. Afterward, you can temporarily mount it to a convenient location, such as /mnt/2tb, to facilitate the file transfer. Use commands like mkdir /mnt/2tb (to create the mount point) and mount /dev/sdX1 /mnt/2tb (replace /dev/sdX1 with your 2TB drive partition).
  2. Move Files from the 256GB Drive to the 2TB Drive: Utilize rsync for efficient file copying with command syntax like rsync -avhP /source/path/ /mnt/2tb/target/path/. Replace /source/path/ with the current location of the files on your 256GB NVMe drive that you want to move, and /mnt/2tb/target/path/ with the corresponding target directory on your 2TB drive. This step ensures that all files are copied over securely and with their original permissions and metadata intact.
  3. Permanently Mount the 2TB Drive to the Desired Directory: After transferring all necessary files, you’ll need to unmount the 2TB drive from /mnt/2tb and then mount it to /DATA/AppData/big-bear-immich/upload. Before doing so, ensure that /DATA/AppData/big-bear-immich/upload is correctly specified in your /etc/fstab file with the appropriate mount options for your 2TB drive. This step may look something like editing /etc/fstab to add a line like:
UUID=xxx-xxx-xxx-xxx /DATA/AppData/big-bear-immich/upload ext4 defaults 0 2

Replace UUID=xxx-xxx-xxx-xxx with the UUID of your 2TB partition, which can be found with the command blkid. This ensures that the drive is mounted automatically at the desired location on every boot.

Thanks, will try and report back

I did some changes to the command you suggested and is working now.

/dev/disk/by-uuid/XXXX-XXXX /DATA/AppData/big-bear-immich/upload exfat defaults 0 2

image

Awesome, glad it’s working. I see you’re using exfat; you might have issues with exfat. I would recommend: ext4