Immich on CasaOS update to latest version issue

Hey guys,

I’m new here after building CasaOS over the past few months. I installed Immich from the repo and I love it. However I’m now stuck as my mobile app wants me to update to 1.106.0. Now my server version is quite old, ie I don’t think I’ve ever updated since I installed. (I had a nightmare start with v1 of my build so I got scared to touch it haha). So I’m on 1.105.1 but I get the attached when trying to change to the latest build.

I hope you guys can help! I’ve tried rebooting Casa also to no avail.

Hello Spudgun91,

That’s a lot of versions in the world of Immich.

Are you installing Immich with BigBearCasaOS?

Because BigBearCasaOS has


not the latest tag.

Thank you for your reply. So yeah, forgive me if I’m doing this completely wrong but how would I go about updating to the latest version?

It should of already been updated.

1st Possible Solution

You can try to uninstall Immich app, but don’t delete the AppData on uninstall and install it again. Sometimes I’ve had reports of it getting stuck.

2nd Possible Solution

Uninstalling the app store and then reinstalling might fix the glitch.

3rd Possible Solution

You can try to reinstall CasaOS completely.

Thank you. I’ll give it a go and let you know!

1 Like

Thanks, the reinstall worked!

1 Like

I’m glad it’s working now! You’re welcome!

Hello, I’m currently experiencing the same issue as you were but reinstalling both Immich and the app store doesn’t seem to install the newest version. I’m still stuck at 1.105.1. Can you clarify what you mean by “reinstall”? Did you reinstall just Immich or the whole CasaOS?

Hello, is there an update to Immich on CasaOS bigbear store? I am stuck on version 1.105.1 and there is now v1.107.2. My android app no longer works because it needs to be higher than 1.106.

When i go to update in the app store, i just says ‘Launch and Open’ and does not give me a way to update. Any ideas?

Can you try to reboot CasaOS sometimes gets stuck.

i’ve tried to reboot, but still the same. When I click on the menu icon on the immich app and click ‘check and update’, a popup menu from the top says ‘unable to update at the moment’.

any ideas?

I face similar issue. removed Immich completly and even tried readding bigbear repo. It just says manifest unknown. Everything set as default

What’s the full error?

That’s not normal is it giving you that error for all the apps or just the ones from BigBearCasaOS?

You can get more info with:

where can i check that? RIght now i am reinstalling casa os. The issue is only with immich.
Issue might be my docker install.

Do you want delete all containers? Y/n :y
         Do you want delete all images? Y/n :y
         Do you want delete all AppData of CasaOS? Y/n :y
[ INFO ] Start deleting containers.
Error response from daemon: page not found
[FAILED] Failed to stop containers.
Error response from daemon: page not found
[FAILED] Failed to delete all containers.
[ INFO ] Start deleting all images.
Error response from daemon: page not found
[FAILED] Failed to delete all images.
[ INFO ] Stopping casaos-gateway.service...

I would try:

Also this one updates docker and docker compose:

Docker is working properly. Freshly installed casaos. Immich without AI is installing but not the normal immich.

All options are default.

No, it doesn’t do that with other apps. The other apps give a checkmark with ‘compose app big bear pihole unbound is up to date’

The health check says exactly the result as in your video, ‘service logs: errors found’ and ’ all casaOS services are up and running’

Is there a way to manually update?

1 Like

Yes, i think there is something definitely wrong with Immich Machine learning package. Both AIO and non-ML works perfectly.

You’re right It looks like I missed a v in the version tag. My bad. Should be fine now.