Installing Cloudflare Tunnels on Proxmox Via Cloudflared LXC - Network Error

Hi there,

i’m new to Proxmox and after following the YouTube Tutorial from [Novaspirit Tech] 5 Things I Would Do On Fresh Install Of ProxMox ( i quickly switched to the Cloudflare LXC Tutorial from BigBear Step-by-Step Guide: Installing Cloudflare Tunnels on Proxmox ( After typing in the command from the video, the installation starts but it fails into a network error.

/ / / __ / / / / _________ / /
/ / / / __ / / / / __ / /
/ / __ `/ / _ / __ /
/ /
/ / /
/ / /
/ / /
/ / __/ / /
/ / / / __/ /
/ /
/_/_,/_,// //_,// ___/_,/

Using Default Settings
Using Distribution: debian
Using debian Version: 12
Using Container Type: 1
Using Root Password: Automatic Login
Using Container ID: 101
Using Hostname: cloudflared
Using Disk Size: 2GB
Allocated Cores 1
Allocated Ram 512
Using Bridge: vmbr0
Using Static IP Address: dhcp
Using Gateway IP Address: Default
Using Apt-Cacher IP Address: Default
Disable IPv6: No
Using Interface MTU Size: Default
Using DNS Search Domain: Host
Using DNS Server Address: Host
Using MAC Address: Default
Using VLAN Tag: Default
Enable Root SSH Access: No
Enable Verbose Mode: No
Creating a Cloudflared LXC using the above default settings
✓ Using local for Template Storage.
✓ Using ssd for Container Storage.
✓ Updated LXC Template List
✓ LXC Container 101 was successfully created.
✓ Started LXC Container
-✗ No Network! ntainer OS
✗ No Network After 10 Tries
🖧 Check Network Settings

It’s a clean Proxmox install. I don’t know if i have to do some network stuff before doing this. Ping and nslookup to github ist working.

The installation fails but the “container” is build. But i need credentials to log in. (I think it’s the problem some guys are commenting under the video in the last months)

Someone an idea how to fix it?

Thanks :sweat_smile:

Awesome, glad you found the video. Here are some steps to check:.

  1. Verify Network Bridge Configuration: Ensure that your Proxmox host’s network bridge (vmbr0, as per your setup) is correctly configured. This bridge should be associated with a working physical network interface. You can check and edit the network settings in Proxmox VE through the “System” > “Network” section in the Proxmox web interface.

  2. Container Network Configuration: Since your container is set to use DHCP for obtaining an IP address, ensure that there is a DHCP server running in your network that can serve IP addresses to your container. If you are unsure, you can temporarily set a static IP for the container that matches your network’s configuration to test connectivity.

Hey, thanks for the quick reply.

I’m a dummy. My Proxmox test lab is on my test network. It has DHCP disabled. After you wrote it down I immediately thought of that. After enabling DHCP on the test network it works fine.

Thanks :grinning:

1 Like