Issues installing MariaDB on CasaOS

I recently installed CasaOS and am following BigBear’s content on YouTube, where he presents the installation of MariaDB and NextCloud on CasaOS.

However, when using the command: mysql -h casaos_ip -P 3306 -u my_user -p to connect to the MariaDB server, I encounter the following error:
ERROR 2059 (HY000): Plugin http could not be loaded: Error loading shared library /usr/lib/mariadb/plugin/ No such file or directory

In fact, I don`t have this file, but I followed the tutorial step by step.

Can anyone help me?

Thank you in advance.

Are you connecting with the right login information?

Yes, I even changed the password to an easier one to check this problem.

But I just managed to solve my issue. I had configured the host as HTTP, which is why it wasn’t working. Changing it to HTTPS worked without any problems.

Thank you!

Glad you got it solved. So you where not using the LAN IP of your CasaOS?

Yes, I am using it. But I had to configure the web UI to HTTPS instead of HTTP.

1 Like