Nextcloud Errors CasaOS

  • The “Strict-Transport-Security” HTTP header is not set to at least “15552000” seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips :arrow_upper_right:.

The strict error says to find the apache folder,but I dont see one.

In the Docker container, the apache2 file is located at:

/etc/apache2/apache2.conf

Sorry for the late reply. I needed to test the container before I told you then I forgot to come back to the post.

Thanks found it. Do I need to paste code from the webpage?
Under
“Enable HTTP Strict Transport Security”

https://docs.nextcloud.com/server/28/admin_manual/installation/harden_server.html

You can set a volume bind for the path and change it in the files manager.

[quote=“dragonfire1119, post:4, topic:522”]
set a volume bind for the path and change it in the files manager.

I’ll have to read on how to do that.

I would recommend you put a reverse proxy in front of NextCloud because the NextCloud image doesn’t use https. You can use Caddy or Nginx Proxy Manager for the reverse proxy.

If you don’t want to poke holes in your firewall, you can also use Cloudflare Tunnels or a VPN. If you need to access it away from home,.

If you go with Cloudflare Tunnels, I recommend you add Cloudflare Access:

You can’t stream video on Cloudflare Tunnels.

Caddy seems to get some good reviews. I see an option for an Ubuntu or Docker install. Does it make a difference? I’m using both.

Hello! I seem to have the same trouble enabling HTTPS for my nextcloud instance.

From what I understand, I should

  1. leave the default parameters untouched:
    for the cron:
    image
    for the nextcloud container:
    OVERWRITEPROTOCOL = HTTP

  2. configure Nginx Proxy Manager as follow:
    proxy host to my domain, pointing to ‘http://192.168.1.177:7580’ with SSL and a Let’s Encrypt certificate enabled

With this config, the url with my domain leads to an error, and Nextcloud is only available through the IP adress and only http.

What should i do ?
Thank you for your help!