Penpot 2.0 update problem

Hi there,

First I wanted to thank you for your work on BigBearCasaOS.

I have an issue as I’m using Penpot and noticed on Github that looks like you have pushed a 2.0 update I’m correct? But I tried to update it via CasaOS and it’s still on 1.19 even after re-installing it.
Is this one ready to be pushed or not yet?


Hello, yes, 2.0 should be ready to be updated. I just tested it, and it did update.

1st Possible Solution

You can try to uninstall it, but don’t delete the AppData on uninstall and install it again. Sometimes I’ve had reports of it getting stuck.

2nd Possible Solution

Uninstalling the app store and then reinstalling might fix the glitch.

3rd Possible Solution

You can try to reinstall CasaOS completely.

Thanks for tips unfortunately I dried reinstall app and this didn’t worked.
I tried remove App Store and add it again, the same results.

But noticed where is the problem.

I checked Penpot settings and noticed that docker image is fine but within tags I was able to switch manually between 1.19.3 and 2.0 I switched frontend and backend to 2.0, saved and installation update have started.
So problem fixed, although it never launched on its own when I’ve been using check and update option. So not sure if this is related to CasaOS or something else. I need to check closely logs. Will check them tomorrow.

Where are you able to check the logs? Also, you might try reinstalling CasaOS sometimes, which has fixed issues in the past.

I tried to check logs and look for what could cause that issue but I couldn’t find anything specific.
I did a few tests by reinstalling some other apps and updating them, and mostly all of them were updated without issue, although it seems as if this issue could be repetitive as I had a similar problem with different apps on CasaOS while updating just can’t recall which one was that as it was about 3 months ago.
Maybe I’ll try to re-install CasaOS as this could be something related but so far no issues with any other app. But will keep an eye on it and will check with future updates.

Where you able to get this solved?