Pterodactyl on CasaOS

Hello, can you make a tutorial on CasaOS for Pterodactyl.

I have made it run PANEL, but Wings doesnt run. I made the node, but node always says, cant connect to node, check browser console.

Im running it on homebase server, without domain.

1 Like

Yes Ill add it it on my todo list to make a video.

Have you tried the panel and wings in BigBearCasaOS?

Stay up to date with the BigBearYouTube Roadmap here:

Hey. First thanks.
Second, yes with this casaosAppStore i did test. And have those problems. I was testing, because of your AppStore.

I’ll add it to my to-do list to look into. Thanks for reporting. If you know how to fix it or think something is wrong, feel free to submit a pull request.

Ok thanks,

Really don’t know what is the problem. But WINGS doesnt stay running. So the node cant connect to it. I did put config.yml in AppData/Bigbeartech-pterodactyl-wings/etc/

But cant connect. I was testing today for almost 4h :joy:

I looked into this and got panel and wings communicating. I released an update to BigBearCasaOS.

Screenshot 2023-11-07 at 10.11.00 AM

Can you show the wings container settings in the CasaOS UI?

Ports on wings should be:

Can you try to restart the wings?

Yes, first 2second is color, then back to gray.

I found that if i disable panel, then wings stay running and is color.

Can you get the logs from wings and panel:

bash -c "$(wget -qLO -"

Wings :

Copyright © 2018 - 2023 Dane Everitt & Contributors
Source: GitHub - pterodactyl/wings: The server control plane for Pterodactyl Panel. Written from the ground-up with security, speed, and stability in mind.
This software is made available under the terms of the MIT license.
The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.
INFO: [Nov 7 17:17:29.271] loading configuration from file config_file=/etc/pterodactyl/config.yml
INFO: [Nov 7 17:17:29.271] configured wings with system timezone timezone=UTC
INFO: [Nov 7 17:17:29.271] configured system user successfully gid=988 uid=988 username=pterodactyl
INFO: [Nov 7 17:17:29.273] fetching list of servers from API
INFO: [Nov 7 17:17:29.430] processing servers returned by the API total_configs=0
INFO: [Nov 7 17:17:29.430] finished processing server configurations duration=220.697µs
INFO: [Nov 7 17:17:29.432] creating missing pterodactyl0 interface, this could take a few seconds…
FATAL: [Nov 7 17:17:29.433] failed to configure docker environment error=Error
response from daemon: Pool overlaps with other one on this address space
Error response from daemon: Pool overlaps with other one on this address space

On Panel:

Is everything running. No errors

Troubleshooting Docker Network Conflicts

Step 1: List Existing Docker Networks

Run the following command to list all existing Docker networks:

docker network ls

This command will display all networks currently managed by Docker. Look for any networks that might be conflicting with the pterodactyl0 network.

Step 2: Inspect Conflicting Networks

To get more details about a specific network (for example, bridge or any custom network), use:

docker network inspect [network_name]

Replace [network_name] with the actual name of the network you want to inspect. Look for the Subnet configuration under the IPAM section.

Step 3: Remove or Reconfigure Conflicting Networks

If you find a network that you believe is causing the conflict and it’s safe to remove (i.e., it’s not in use by other critical containers), you can remove it with:

docker network rm [network_name]

If you need to keep the network, consider reconfiguring it to use a different subnet that doesn’t conflict with what Pterodactyl requires.

Step 4: Adjust Pterodactyl Network Configuration

If Pterodactyl is configured to use a specific subnet that is causing the conflict, adjust the configuration to use a different subnet. This is typically done in the Pterodactyl configuration files.

Step 5: Restart Docker Service

Sometimes, simply restarting the Docker service can resolve temporary network conflicts. Use the following command to restart Docker:

sudo systemctl restart docker

Step 6: Check System Network Configuration

Ensure there are no conflicts with the host system’s network configuration. Check for static IP assignments and other services that may interfere with Docker’s networking.

Step 7: Docker Network Prune (Caution Advised)

If there are no important containers running and you want to clean up all unused networks, you can use the following command:

docker network prune

Be very cautious with this command, as it will remove all networks not used by at least one container.

I made it running. I was having old pterodactyl docker inside. Thanks a lot

Awesome glad you got it running :slight_smile:

Did you install Docker with snap?

I have installed docker with Ubunto install usb. I did just ran your script, it says, that everything is comunicating.

Did just reboot, gonna test tomorrow. Thanks for now.

First line says, docker is not installed via snap.

Ok fixed it.

1 Like