Ring Camera Scrypted not adding to Apple Home

hey! In scripted I’m adding a ring camera using the ring and homekit plugins but when I scan the code it loads for about 5 minutes then says unable to reach the accessory

Have you looked at my video here:

Normally, it’s because of the mDNS.

Yeah I did that it’s not the problem

That’s weird; normally, it is. Once I fixed mDNS, mine worked fine.

  1. Ensure that both your Scrypted and Homehub and the device you’re using to scan the HomeKit code are on the same Wi-Fi network and that the network is stable.

  2. Sometimes, simply restarting your devices can resolve connectivity issues. Restart your Ring camera, your router, and the device you’re using for setup.

Are you able to add another device from Scrypted to Homekit?

Are you getting the same error as in the YouTube video?

Could it be an issue that my ring is on one network the server I’m hosting for scrypted is on another but my iOS device is on the same one as the ring?

Yes, that would more than likely be the issue.

  • Connect both your Home Hub and the server running Scrypted to the same Network.
  • If you are using VLANs or multiple subnets, make sure that appropriate routing and firewall rules are in place to allow the necessary local network traffic for HomeKit and Scrypted.

You can also set up Avahi.

Devices are now on the same network and the same issue is persisting

Where are you able to get this working?