Updating Immich from 1.90.2 on CasaOS

Any suggestions on what I can try next? Thanks

Can you try this solution?

1 Like

pi4@piserver:~ $ bash -c “$(wget -qO - https://raw.githubusercontent.com/gartisk/big-bear-scripts/master/casaos-immich-vectors-upgrade/run.sh)” – -u casaos -p 0.1.11 -n 0.2.0
CREATE SCHEMA
UPDATE 0
UPDATE 0
ERROR: could not open extension control file “/usr/local/share/postgresql/extension/vectors.control”: No such file or directory
ERROR: extension “vectors” does not exist
UPDATE 0
ERROR: extension “vectors” does not exist
ERROR: function pgvectors_upgrade() does not exist
LINE 1: SELECT pgvectors_upgrade();
^
HINT: No function matches the given name and argument types. You might need to add explicit type casts.
immich-machine-learning is running, stopping…
immich-machine-learning
immich-machine-learning has been restarted.
immich-postgres is running, stopping…
immich-postgres
immich-postgres has been restarted.
immich-server is running, stopping…
immich-server
immich-server has been restarted.
immich-microservices is running, stopping…
immich-microservices
immich-microservices has been restarted.
immich-redis is running, stopping…
immich-redis
immich-redis has been restarted.
immich-machine-learning is running.
immich-postgres is running.
immich-server is running.
immich-microservices is running.
immich-redis is running.
UPDATE 0
Finished

How did you update Immich?

I haven’t been able to yet. I am trying by clicking the three dots, check then update. I get the error “Unable to update at the moment!”

Can you look in the Browser Console developer tools and see if there’s any errors?

Also, can you run a health check to see if anything is in the logs after you click the check and then update button?

This was in the console of the browser. I think that is what you wanted to see.

   Failed to load resource: the server responded with a status of 404 (Not Found)

/v2/app_management/compose/big-bear-immich:1

   Failed to load resource: the server responded with a status of 500 (Internal Server Error)

/v2/app_management/compose/big-bear-immich:1

   Failed to load resource: the server responded with a status of 500 (Internal Server Error)

appgrid:1

   Failed to load resource: the server responded with a status of 401 (Unauthorized)

Here is the healthcheck

pi4@piserver:~ $ bash -c “$(wget -qLO - https://raw.githubusercontent.com/bigbeartechworld/big-bear-scripts/master/casaos-healthcheck/run.sh)”

BigBearCasaOS Healthcheck

Here is some links
https://community.bigbeartechworld.com
Big Bear Tech World · GitHub

If you would like to support me, please consider buying me a tea


System Information:

Operating System: Debian GNU/Linux 12 (bookworm)
Kernel: 6.1.0-rpi4-rpi-v8
Uptime: up 3 days, 23 hours, 6 minutes
Packages: 944
Shell: /bin/bash
Terminal: xterm-256color
CPU: Cortex-A72
GPU:
Memory: 7.6Gi Total, 2.2Gi Used


CasaOS Healthcheck:

The local IP address is: 192.168.1.155
The port number is: 80
You can access it in the browser at: http://192.168.1.155:80
sudo: ufw: command not found
The port 80 is not blocked by UFW.
Service casaos-app-management.service is running.
Service casaos-gateway.service is running.
Service casaos-local-storage.service is running.
Service casaos-message-bus.service is running.
Service casaos-user-service.service is running.
Service casaos.service is running.
Errors in casaos-app-management.service logs:
Mar 18 17:14:54 piserver casaos-app-management[3232]: 2024-03-18T17:14:54.331-0400 error store compose app not found, thus no update available {“storeAppID”: “playful_amor”, “func”: “service.(*ComposeApp).IsUpdateAvailable”, “file”: “/home/runner/work/CasaOS-AppManagement/CasaOS-AppManagement/service/compose_app.go”, “line”: 181}
Mar 18 17:14:54 piserver casaos-app-management[3232]: 2024-03-18T17:14:54.347-0400 error store compose app not found, thus no update available {“storeAppID”: “zen_samuel”, “func”: “service.(*ComposeApp).IsUpdateAvailable”, “file”: “/home/runner/work/CasaOS-AppManagement/CasaOS-AppManagement/service/compose_app.go”, “line”: 181}
Mar 18 17:14:54 piserver casaos-app-management[3232]: {“time”:“2024-03-18T17:14:54.482949817-04:00”,“id”:“”,“remote_ip”:“192.168.1.217”,“host”:“192.168.1.155”,“method”:“GET”,“uri”:“/v2/app_management/web/appgrid”,“user_agent”:“Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/122.0.0.0 Safari/537.36”,“status”:200,“error”:“”,“latency”:381459147,“latency_human”:“381.459147ms”,“bytes_in”:0,“bytes_out”:3325}

Errors in casaos-local-storage.service logs:
Mar 15 10:41:09 piserver casaos-local-storage[827]: 2024-03-15T10:41:09.980-0400 error failed to publish event to message bus {“status”: “404 Not Found”, “responseError”: “json: unsupported type: func() (io.ReadCloser, error)”, “func”: “service.(*notifyServer).SendNotify”, “file”: “/DATA/project/CasaOS-LocalStorage/service/notify.go”, “line”: 32}
Mar 16 08:39:49 piserver casaos-local-storage[827]: 2024-03-16T08:39:49.435-0400 error failed to publish event to message bus {“status”: “404 Not Found”, “responseError”: “json: unsupported type: func() (io.ReadCloser, error)”, “func”: “service.(*notifyServer).SendNotify”, “file”: “/DATA/project/CasaOS-LocalStorage/service/notify.go”, “line”: 32}
Mar 16 15:58:31 piserver casaos-local-storage[827]: 2024-03-16T15:58:31.467-0400 error failed to publish event to message bus {“status”: “404 Not Found”, “responseError”: “json: unsupported type: func() (io.ReadCloser, error)”, “func”: “service.(*notifyServer).SendNotify”, “file”: “/DATA/project/CasaOS-LocalStorage/service/notify.go”, “line”: 32}
Mar 16 16:35:22 piserver casaos-local-storage[827]: 2024-03-16T16:35:22.632-0400 error failed to publish event to message bus {“status”: “404 Not Found”, “responseError”: “json: unsupported type: func() (io.ReadCloser, error)”, “func”: “service.(*notifyServer).SendNotify”, “file”: “/DATA/project/CasaOS-LocalStorage/service/notify.go”, “line”: 32}
Mar 17 16:23:00 piserver casaos-local-storage[827]: 2024-03-17T16:23:00.092-0400 error failed to publish event to message bus {“status”: “404 Not Found”, “responseError”: “json: unsupported type: func() (io.ReadCloser, error)”, “func”: “service.(*notifyServer).SendNotify”, “file”: “/DATA/project/CasaOS-LocalStorage/service/notify.go”, “line”: 32}
Mar 18 13:12:10 piserver casaos-local-storage[827]: 2024-03-18T13:12:10.497-0400 error failed to publish event to message bus {“status”: “404 Not Found”, “responseError”: “json: unsupported type: func() (io.ReadCloser, error)”, “func”: “service.(*notifyServer).SendNotify”, “file”: “/DATA/project/CasaOS-LocalStorage/service/notify.go”, “line”: 32}
Mar 18 14:35:19 piserver casaos-local-storage[827]: 2024-03-18T14:35:19.968-0400 error failed to publish event to message bus {“status”: “404 Not Found”, “responseError”: “json: unsupported type: func() (io.ReadCloser, error)”, “func”: “service.(*notifyServer).SendNotify”, “file”: “/DATA/project/CasaOS-LocalStorage/service/notify.go”, “line”: 32}

Errors in casaos-message-bus.service logs:
Mar 18 17:15:03 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:03.038157805-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1229713,“latency_human”:“1.229713ms”,“bytes_in”:945,“bytes_out”:1102}
Mar 18 17:15:08 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:08.072603821-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1780024,“latency_human”:“1.780024ms”,“bytes_in”:942,“bytes_out”:1099}
Mar 18 17:15:13 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:13.037214454-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1337139,“latency_human”:“1.337139ms”,“bytes_in”:944,“bytes_out”:1101}
Mar 18 17:15:18 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:18.037207352-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1239880,“latency_human”:“1.23988ms”,“bytes_in”:944,“bytes_out”:1101}
Mar 18 17:15:23 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:23.086993003-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1595507,“latency_human”:“1.595507ms”,“bytes_in”:944,“bytes_out”:1101}
Mar 18 17:15:28 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:28.041130037-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1464008,“latency_human”:“1.464008ms”,“bytes_in”:944,“bytes_out”:1101}
Mar 18 17:15:33 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:33.039014852-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1226972,“latency_human”:“1.226972ms”,“bytes_in”:945,“bytes_out”:1102}
Mar 18 17:15:38 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:38.043140066-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:1288695,“latency_human”:“1.288695ms”,“bytes_in”:944,“bytes_out”:1101}
Mar 18 17:15:43 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:43.596181025-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:5646830,“latency_human”:“5.64683ms”,“bytes_in”:943,“bytes_out”:1100}
Mar 18 17:15:48 piserver casaos-message-bus[765]: {“time”:“2024-03-18T17:15:48.363229465-04:00”,“id”:“”,“remote_ip”:“127.0.0.1”,“host”:“127.0.0.1:34439”,“method”:“POST”,“uri”:“/v2/message_bus/event/casaos/casaos:system:utilization”,“user_agent”:“Go-http-client/1.1”,“status”:200,“error”:“”,“latency”:2347983,“latency_human”:“2.347983ms”,“bytes_in”:943,“bytes_out”:1100}

Service Logs: Errors Found
All casaos services are up and running.

Check for updates

Click on the check, then update button in the CasaOS UI.

Look in logs

Run this:

cat /var/log/casaos/app-management.log | grep immich

CasaOS shows up to date version 0.4.7

pi4@piserver:~ $ cat /var/log/casaos/app-management.log | grep immich
cat: /var/log/casaos/app-management.log: Permission denied

Try adding sudo:

sudo cat /var/log/casaos/app-management.log | grep immich

There are many lines, but I think they are repeating so I only pasted a few

sudo cat /var/log/casaos/app-management.log | grep immich
2024-03-15T15:59:20.355-0400 info main apps of local app and store app have different image tag, thus update is available {“local”: “Package immich-server · GitHub”, “store”: “Package immich-server · GitHub”, “func”: “service.(*ComposeApp).IsUpdateAvailableWith”, “file”: “/home/runner/work/CasaOS-AppManagement/CasaOS-AppManagement/service/compose_app.go”, “line”: 227}
2024-03-15T16:00:20.352-0400 info main apps of local app and store app have different image tag, thus update is available {“local”: “Package immich-server · GitHub”, “store”: “Package immich-server · GitHub”, “func”: “service.(*ComposeApp).IsUpdateAvailableWith”, “file”: “/home/runner/work/CasaOS-AppManagement/CasaOS-AppManagement/service/compose_app.go”, “line”: 227}

Did you install Immich from BigBearCasaOS? Also, have you customized Docker Compose in any way?

No, I had CasaOS already and installed your app store after. I have not customized anything.

So you still have BigBearCasaOS installed?

Also, can you screenshot the app settings?

I have the regular CasaOS with BigBear App Store installed and it is still installed.

image

I just installed Immich on my testing CasaOS, then changed the version on Docker Compose and went back into CasaOS, clicking Check, then updating, and it updated to the latest.

Should I just uninstall and reinstall a new Immich? Do you know if it is possible to not have to redo everything in Immich?

Ok, here are the options since the automatic update is not working.

Option 1

Edit the docker compose manually by copying and pasting the docker compose from the BigBearCasaOS repo and using:

Option 2

Uninstall the app and don’t delete the app data. You should also backup anything important.

Option 3

Reinstall your CasaOS.

1 Like

Okay, thanks for all your help. Let me take a look at these and decide which one to proceed with.

I reinstalled CasaOS and Immich said it was up to date still at version 1.90.2 so I reinstalled just the app and it is up to date now and everything looks good. Thanks again for your help!

2 Likes